<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://mcccagora.com/xmlrpc.php">

	<title>&#8216;Animal Crossing: New Horizons&#8217; gives players an escape &#8211; Mcccagora</title>
<style type="text/css">			.heateorSssInstagramBackground{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateorSssSharing,.heateor_sss_standard_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_horizontal_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_horizontal_sharing .heateorSssSharing:hover,.heateor_sss_standard_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing .heateorSssSharing,.heateor_sss_floating_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_vertical_sharing .heateorSssSharing:hover,.heateor_sss_floating_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}@media screen and (max-width:783px) {.heateor_sss_floating_follow_icons_container{display:none!important}}</style><script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '551861394', '0');</script><link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mcccagora &raquo; Feed" href="http://mcccagora.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mcccagora &raquo; Comments Feed" href="http://mcccagora.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/mcccagora.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://mcccagora.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='pdfemb-gutenberg-block-backend-js-css'  href='http://mcccagora.com/wp-content/plugins/PDFEmbedder-premium/css/pdfemb-blocks.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='customization-style-css'  href='http://mcccagora.com/wp-content/plugins/customization/css/style.css?ver=1.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='wpfc-css'  href='http://mcccagora.com/wp-content/plugins/gs-facebook-comments/public/css/wpfc-public.css?ver=1.5' type='text/css' media='all' />
<link rel='stylesheet' id='zoom-theme-utils-css-css'  href='http://mcccagora.com/wp-content/themes/tribune/functions/wpzoom/assets/css/theme-utils.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='tribune-google-fonts-css'  href='//fonts.googleapis.com/css?family=Merriweather%3Aregular%2C700%2C700i%2Citalic%7CPlayfair+Display%3Aregular%2C700%7CMontserrat%3Aregular%2C700%7CRoboto+Condensed%3Aregular%2C700&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='tribune-style-css'  href='http://mcccagora.com/wp-content/themes/tribune/style.css?ver=4.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css'  href='http://mcccagora.com/wp-content/themes/tribune/css/media-queries.css?ver=4.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribune-google-font-default-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700%7CPlayfair+Display%3A400%2C700%7CRoboto+Condensed%3A400%2C700%7CMerriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic&#038;subset=latin%2Cgreek%2Ccyrillic&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://mcccagora.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='socicon-css'  href='http://mcccagora.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/socicon.css?ver=20203101' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://mcccagora.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/genericons.css?ver=20180625' type='text/css' media='all' />
<link rel='stylesheet' id='academicons-css'  href='http://mcccagora.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/academicons.min.css?ver=20190406' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://mcccagora.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome.min.css?ver=20180625' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css'  href='http://mcccagora.com/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.8' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_sharing_default_svg-css'  href='http://mcccagora.com/wp-content/plugins/sassy-social-share/admin/css/sassy-social-share-svg.css?ver=3.3.8' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-custom-css'  href='http://mcccagora.com/wp-content/themes/tribune/custom.css?ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript' src='http://mcccagora.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"69a3fc0e7d","_ajax_url":"http:\/\/mcccagora.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?ver=5.133.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"http:\/\/mcccagora.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"http:\/\/mcccagora.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.133.1'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/plugins/gs-facebook-comments/public/js/wpfc-public.js?ver=1.5'></script>
<link rel='https://api.w.org/' href='http://mcccagora.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://mcccagora.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://mcccagora.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='MCCC donates, loans equipment to assist during pandemic' href='http://mcccagora.com/2020/03/27/mccc-donates-loans-equipment-to-assist-during-pandemic/' />
<link rel='next' title='Covid-19 affects campus construction' href='http://mcccagora.com/2020/04/02/covid-19-affects-construction-at-mccc/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="http://mcccagora.com/2020/03/31/animal-crossing-new-horizons-gives-players-a-silver-lining/" />
<link rel='shortlink' href='http://mcccagora.com/?p=4017' />
<link rel="alternate" type="application/json+oembed" href="http://mcccagora.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmcccagora.com%2F2020%2F03%2F31%2Fanimal-crossing-new-horizons-gives-players-a-silver-lining%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://mcccagora.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmcccagora.com%2F2020%2F03%2F31%2Fanimal-crossing-new-horizons-gives-players-a-silver-lining%2F&#038;format=xml" />
            <!-- Global site tag (gtag.js) - Google Analytics -->
            <script async src="https://www.googletagmanager.com/gtag/js?id=UA-147478929-1"></script>
            <script>
                window.dataLayer = window.dataLayer || [];

                function gtag() {
                    dataLayer.push(arguments);
                }

                gtag('js', new Date());

                gtag('config', 'UA-147478929-1');
            </script>
                <style type="text/css">
        ol.popular-posts li a { color: #000000; }
        ol.popular-posts li a:hover { color: #000000; }
    </style>
    <!-- WPZOOM Theme / Framework -->
<meta name="generator" content="Tribune 4.2.0" />
<meta name="generator" content="WPZOOM Framework 1.8.6" />
<script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script>
<!-- Begin Theme Custom CSS -->
<style type="text/css" id="tribune-custom-css">
.navbar-brand .tagline{display:none;}.navbar-brand .header_date{display:none;}.main-navbar{background:#000000;}
</style>
<!-- End Theme Custom CSS -->

<!-- START - Open Graph and Twitter Card Tags 2.2.7.2 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_US"/>
  <meta property="og:site_name" content="Mcccagora"/>
  <meta property="og:title" content="&#039;Animal Crossing: New Horizons&#039; gives players an escape"/>
  <meta property="og:url" content="http://mcccagora.com/2020/03/31/animal-crossing-new-horizons-gives-players-a-silver-lining/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="I’ve spent the last week on a private island resort, free of any worldwide pandemics.

This island, named “Epicana,” is where most of my adventuring takes place in Nintendo’s newly released game &quot;Animal Crossing: New Horizons.&quot;



Released March 20, the game centers on you living in a town wit"/>
  <meta property="og:image" content="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-cover.jpg"/>
  <meta property="og:image:url" content="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-cover.jpg"/>
  <meta property="article:published_time" content="2020-03-31T22:52:07-04:00"/>
  <meta property="article:modified_time" content="2020-03-31T22:58:27-04:00" />
  <meta property="og:updated_time" content="2020-03-31T22:58:27-04:00" />
  <meta property="article:section" content="Entertainment"/>
  <meta property="article:publisher" content="https://www.facebook.com/mcccagora"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="&#039;Animal Crossing: New Horizons&#039; gives players an escape"/>
  <meta itemprop="headline" content="&#039;Animal Crossing: New Horizons&#039; gives players an escape"/>
  <meta itemprop="description" content="I’ve spent the last week on a private island resort, free of any worldwide pandemics.

This island, named “Epicana,” is where most of my adventuring takes place in Nintendo’s newly released game &quot;Animal Crossing: New Horizons.&quot;



Released March 20, the game centers on you living in a town wit"/>
  <meta itemprop="image" content="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-cover.jpg"/>
  <meta itemprop="datePublished" content="2020-03-31"/>
  <meta itemprop="dateModified" content="2020-03-31T22:58:27-04:00" />
  <meta itemprop="author" content="Jerry Meade"/>
  <!--<meta itemprop="publisher" content="Mcccagora"/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="&#039;Animal Crossing: New Horizons&#039; gives players an escape"/>
  <meta name="twitter:url" content="http://mcccagora.com/2020/03/31/animal-crossing-new-horizons-gives-players-a-silver-lining/"/>
  <meta name="twitter:description" content="I’ve spent the last week on a private island resort, free of any worldwide pandemics.

This island, named “Epicana,” is where most of my adventuring takes place in Nintendo’s newly released game &quot;Animal Crossing: New Horizons.&quot;



Released March 20, the game centers on you living in a town wit"/>
  <meta name="twitter:image" content="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-cover.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
 <!-- SEO -->
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph and Twitter Card Tags 2.2.7.2 -->
	

	
</head>
<body class="post-template-default single single-post postid-4017 single-format-standard wp-custom-logo">

<div class="site-wrap">

	<div class="page-wrap">

		<header id="header">

			<nav class="navbar" role="navigation">

				<nav class="top-navbar" role="navigation">


					<div class="header_social">
						<div id="zoom-social-icons-widget-3" class="widget zoom-social-icons-widget">
		
		<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-right zoom-social-icons-list--no-labels">

			
								<li class="zoom-social_icons-list__item">
					<a class="zoom-social_icons-list__link" href="https://facebook.com/mcccagora" target="_blank" rel="nofollow">
																		
                                                    <span class="screen-reader-text">facebook</span>
                        
						<span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 18px; padding:5px" ></span>

											</a>
				</li>

			
								<li class="zoom-social_icons-list__item">
					<a class="zoom-social_icons-list__link" href="https://twitter.com/mcccagora" target="_blank" rel="nofollow">
																		
                                                    <span class="screen-reader-text">twitter</span>
                        
						<span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #55acee; font-size: 18px; padding:5px" ></span>

											</a>
				</li>

			
								<li class="zoom-social_icons-list__item">
					<a class="zoom-social_icons-list__link" href="https://instagram.com/mcccagora" target="_blank" rel="nofollow">
																		
                                                    <span class="screen-reader-text">instagram</span>
                        
						<span class="zoom-social_icons-list-span socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#e4405f" style="background-color : #e4405f; font-size: 18px; padding:5px" ></span>

											</a>
				</li>

			
		</ul>

		<div class="clear"></div></div>					</div>


					<div class="navbar-header">
						
					</div>

					<div id="navbar-top">

											</div><!-- #navbar-top -->


				</nav><!-- .navbar -->

				<div class="clear"></div>

			</nav><!-- .navbar -->

            
			<div id="header-inner">


				<div class="navbar-brand">
					<a href="http://mcccagora.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="245" height="100" src="http://mcccagora.com/wp-content/uploads/sites/7/2019/09/cropped-Agora-logo-Fall-2017.jpg" class="custom-logo" alt="Mcccagora" itemprop="logo" /></a>					<span class="tagline"></span>
					<span class="header_date">Friday, April 3, 2020</span>
				</div><!-- .navbar-brand -->


				
				<div class="clear"></div>

			</div><!-- /#header-inner -->


			<nav class="navbar" role="navigation">

				<nav class="main-navbar" role="navigation">


					<div id="sb-search" class="sb-search">
						<form method="get" id="searchform" action="http://mcccagora.com/">
	<input type="search" class="sb-search-input" placeholder="Enter your keywords..."  name="s" id="s" />
    <input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
    <span class="sb-icon-search"></span>
</form>					</div>


					<div class="navbar-header">
						
							<a class="navbar-toggle" href="#menu-main-slide">
                                <span class="toggle-bars">
                                    <span class="icon-bar"></span>
                                    <span class="icon-bar"></span>
                                    <span class="icon-bar"></span>
                                </span>
								<span class="toggle-text">Menu</span>
							</a>


							<div id="menu-main-slide" class="menu-categories-menu-container"><ul id="menu-categories-menu" class="menu"><li id="menu-item-1687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1687"><a href="http://mcccagora.com/category/features/">Features</a></li>
<li id="menu-item-1685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1685"><a href="http://mcccagora.com/category/news/">News</a></li>
<li id="menu-item-1692" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1692"><a href="http://mcccagora.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-1689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1689"><a href="http://mcccagora.com/category/opinion/">Opinion</a></li>
<li id="menu-item-1694" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1694"><a href="http://mcccagora.com/category/blogs/">Blogs</a></li>
<li id="menu-item-1696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1696"><a href="http://mcccagora.com/category/staff/">Staff</a>
<ul class="sub-menu">
	<li id="menu-item-2217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2217"><a href="http://mcccagora.com/category/old-staff/">Alumni Staff</a></li>
</ul>
</li>
<li id="menu-item-1699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1699"><a href="http://mcccagora.com/classifieds/">Classifieds</a></li>
</ul></div>
					</div>

					<div id="navbar-main">

						<div class="menu-categories-menu-container"><ul id="menu-categories-menu-1" class="nav navbar-nav dropdown sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1687"><a href="http://mcccagora.com/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1685"><a href="http://mcccagora.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1692"><a href="http://mcccagora.com/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1689"><a href="http://mcccagora.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1694"><a href="http://mcccagora.com/category/blogs/">Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1696"><a href="http://mcccagora.com/category/staff/">Staff</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2217"><a href="http://mcccagora.com/category/old-staff/">Alumni Staff</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1699"><a href="http://mcccagora.com/classifieds/">Classifieds</a></li>
</ul></div>
					</div><!-- #navbar-main -->

					<div class="clear"></div>

				</nav><!-- .main-navbar -->

			</nav><!-- .navbar -->

			<div class="clear"></div>

		</header><!-- /#header -->



    <main id="main" role="main">

        
            <div class="content-area">

                <article id="post-4017" class="post-4017 post type-post status-publish format-standard has-post-thumbnail category-entertainment tag-animal-crossing tag-co-op tag-game-review tag-island tag-jerry-meade tag-new-horizons tag-nintendo tag-nintendo-switch tag-switch tag-tom-nook tag-video-game tag-video-game-review tag-video-games tag-villager">


    

    <header class="entry-header">

       <span class="cat-links"><a href="http://mcccagora.com/category/entertainment/" rel="category tag">Entertainment</a></span>
        <h1 class="entry-title">&#8216;Animal Crossing: New Horizons&#8217; gives players an escape</h1>

        <div class="post-meta">

                            <time class="entry-date published updated" datetime="2020-03-31T22:52:07-04:00">
                    March 31, 2020 10:52 pm                </time>
            

            <span class="entry-author vcard author">by <a class="url fn n" href="http://mcccagora.com/author/jerrymeade/">Jerry Meade</a></span>
            
        </div>


    </header><!-- .entry-header -->

    <div class="clear"></div>

    <div class="entry-content">

        
        <p>I’ve spent the last week on a private island resort, free of any worldwide pandemics.</p>
<p>This island, named “Epicana,” is where most of my adventuring takes place in Nintendo’s newly released game &#8220;Animal Crossing: New Horizons.&#8221;</p>
<figure id="attachment_4018" aria-describedby="caption-attachment-4018" style="width: 392px" class="wp-caption alignright"><a href="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay.jpg"><img class="wp-image-4018" src="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-1024x576.jpg" alt="" width="392" height="221" srcset="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-1024x576.jpg 1024w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-300x169.jpg 300w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-768x432.jpg 768w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-431x242.jpg 431w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-862x485.jpg 862w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay.jpg 1280w" sizes="(max-width: 392px) 100vw, 392px" /></a><figcaption id="caption-attachment-4018" class="wp-caption-text">The game features many animal residents to talk to, share gifts with and invite to your island.</figcaption></figure>
<p>Released March 20, the game centers on you living in a town with anthropomorphic animal villagers, while exploring, decorating and utilizing the land as you please.</p>
<p>With there being five main-series games, I still had only played the original title on the GameCube before the release of &#8220;New Horizons.&#8221;</p>
<p>The hype I had for the game was nothing short of extreme.</p>
<p>The premise starts off like the previous series games, you moving to a new town with little to no bells (the game’s currency).</p>
<p>Tom Nook, the only landlord in the game, offers to give you a house, with you then having to pay off that debt.</p>
<p>Unlike other Animal Crossing games that start you off in a populated town, players now begin on a private uninhabited island.</p>
<p>The move there is a vacation package provided by Nook and his two nephews, Timmy and Tommy. You, along with two randomly selected villagers, move to the island with just a tent to live in.</p>
<p>To build your tent into a house, with future room and level add-ons, you must pay Nook thousands of bells.</p>
<p>There are many ways to earn these bells.</p>
<p>Your island is full of resources such as plants, wood, bugs, fish and even fossils you can dig up from the land. You can choose to either sell these materials to Nook for bells, or use them to craft various items in the game.</p>
<p>Crafting can result in the creation of key tools that further your game experience, like the pole vault that first helps you cross your island’s river. The ability to craft will also let you build various furniture, decorations, or apparel that help you design your house and island any way you want.</p>
<p>New Horizons introduces a new game mechanic called the “Nook phone.” This gadget has apps on it that allow you to design patterns to wear, as well as keep track of the creatures you’ve captured and the Nook Miles you&#8217;ve collected.</p>
<figure id="attachment_4025" aria-describedby="caption-attachment-4025" style="width: 300px" class="wp-caption alignleft"><a href="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-2-1-e1585616607642.jpg"><img class="wp-image-4025 size-medium" src="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-2-1-e1585616607642-300x175.jpg" alt="" width="300" height="175" srcset="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-2-1-e1585616607642-300x175.jpg 300w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-2-1-e1585616607642-431x252.jpg 431w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay-2-1-e1585616607642.jpg 707w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption id="caption-attachment-4025" class="wp-caption-text">There are many types of fish to catch, bugs to capture and fossils to unearth throughout New Horizons.</figcaption></figure>
<p>Nook Miles are earned by doing various tasks in your island like catching bugs, planting trees or just talking with other NPCs.</p>
<p>Miles can be spent on upgrades to your tools as well as tickets to visit other islands. With tickets, you can travel to random islands that may have new materials or villagers you can invite to live on your island.</p>
<p>One of my favorite features of the game is visiting your friend’s towns. You can visit individuals who you are already friends on your Nintendo Switch or random users you might share your travel code with.</p>
<p>Having visitors and visiting others adds a fun co-op element to the game, exchanging items or just chatting in general.</p>
<p>The time of year that the game is played will heavily effect items available as well as trigger holiday events. Certain bugs I have caught in the last week might not be available to catch till next March, for example.</p>
<p>The game also utilizes the real-world day cycle, with the time of day matching with what is happening in the outside world. This is a cool way to be immersed in the game and plan out events at specific times. Though for some who can only play at certain parts of the day it might prove to make the game experience a little more challenging.</p>
<p>I’m torn on whether to like or dislike &#8220;New Horizons’&#8221; clock mechanic.</p>
<p>On one hand the game becomes more spread out with new additions being available every day. On the other, certain features such as building upgrades and new villagers moving in take several real-world days to trigger, making game progression some-what tedious.</p>
<p>Timmy and Tommy’s upgraded shop, for instance, is only open from 8 a.m. &#8211; 10 p.m. Any time before or after that you are unable to buy certain items and can only sell materials at 80 percent value.</p>
<p>With this in mind, I have spent many times debating whether or not to perform the game’s ultimate taboo, time travel.</p>
<figure id="attachment_4026" aria-describedby="caption-attachment-4026" style="width: 416px" class="wp-caption alignright"><a href="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay3.jpg"><img class="wp-image-4026" src="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay3-1024x576.jpg" alt="" width="416" height="234" srcset="http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay3-1024x576.jpg 1024w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay3-300x169.jpg 300w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay3-768x432.jpg 768w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay3-431x242.jpg 431w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay3-862x485.jpg 862w, http://mcccagora.com/wp-content/uploads/sites/7/2020/03/AC-gameplay3.jpg 1280w" sizes="(max-width: 416px) 100vw, 416px" /></a><figcaption id="caption-attachment-4026" class="wp-caption-text">Decorating your own house, with furniture and trinkets alike, has become a staple feature in the Animal Crossing series.</figcaption></figure>
<p>Animal Crossing uses the Nintendo Switch system’s internal clock to decide the in-game date and time. Time travelling is manually setting the clock ahead to speed up the process of events.</p>
<p>I ultimately decided to play the game as the developer’s intended, having a guilt-free conscience.</p>
<p>What the game lacks in binge-ability, however, it makes up for with overall charm and customization.</p>
<p>The sheer amount of things to do in the game, as well as customization possibilities is astounding.</p>
<p>For those looking to play the game with companions, there are new Facebook groups with people who have the game.</p>
<p>Seeing what others have created inspires me to up my creativity and expand my island themes.</p>
<p>One thing I’ve noticed in these groups are members discussing the game being an escape from the COVID-19 pandemic.</p>
<p>The game instills a creative hub and way for people to stay connected.</p>
<p>Overall, the calm and relaxing atmosphere of &#8220;Animal Crossing: New Horizons&#8221; makes it a great game to pick up and play.</p>
<p>You never know what new items will be available or what villagers will be visiting your town when starting each day.</p>
<p>&nbsp;</p>
<p>&nbsp;</p>

			  <div 
			  	class = "fb-comments" 
			  	data-href = "http://mcccagora.com/2020/03/31/animal-crossing-new-horizons-gives-players-a-silver-lining/"
			  	data-numposts = "10"
				data-colorscheme = "light"
				data-order-by = "social"
				data-mobile=true>
			  </div>
		  <style>
			.fb_iframe_widget_fluid_desktop iframe {
			    width: 100% !important;
			}
		  </style>
		  <div class='heateorSssClear'></div><div  class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' heateor-sss-data-href='http://mcccagora.com/2020/03/31/animal-crossing-new-horizons-gives-players-a-silver-lining/'><div class='heateor_sss_sharing_title' style="font-weight:bold" ></div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fmcccagora.com%2F2020%2F03%2F31%2Fanimal-crossing-new-horizons-gives-players-a-silver-lining%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?text=%27Animal%20Crossing%3A%20New%20Horizons%27%20gives%20players%20an%20escape&url=http%3A%2F%2Fmcccagora.com%2F2020%2F03%2F31%2Fanimal-crossing-new-horizons-gives-players-a-silver-lining%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Email" Title="Email" class="heateorSssSharing heateorSssEmailBackground"  onclick="window.location.href = 'mailto:?subject=' + decodeURIComponent('%27Animal%20Crossing%3A%20New%20Horizons%27%20gives%20players%20an%20escape' ).replace('&', '%26') + '&body=' + decodeURIComponent('http%3A%2F%2Fmcccagora.com%2F2020%2F03%2F31%2Fanimal-crossing-new-horizons-gives-players-a-silver-lining%2F' )"><ss style="display:block" class="heateorSssSharingSvg heateorSssEmailSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="PrintFriendly" Title="PrintFriendly" class="heateorSssSharing heateorSssPrintFriendlyBackground" onclick='heateorSssPopup("http://www.printfriendly.com/print?url=http%3A%2F%2Fmcccagora.com%2F2020%2F03%2F31%2Fanimal-crossing-new-horizons-gives-players-a-silver-lining%2F&partner=a2a")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssPrintFriendlySvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" title="More" alt="More" class="heateorSssSharing heateorSssMoreBackground" onclick="heateorSssMoreSharingPopup(this, 'http://mcccagora.com/2020/03/31/animal-crossing-new-horizons-gives-players-a-silver-lining/', '%27Animal%20Crossing%3A%20New%20Horizons%27%20gives%20players%20an%20escape', '' )" ><ss style="display:block" class="heateorSssSharingSvg heateorSssMoreSvg"></ss></i></li></ul><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div>
        <div class="clear"></div>

        
    </div><!-- .entry-content -->


    <footer class="entry-footer">

        
        <div class="tag_list">Tags: <a href="http://mcccagora.com/tag/animal-crossing/" rel="tag">Animal Crossing</a>, <a href="http://mcccagora.com/tag/co-op/" rel="tag">co-op</a>, <a href="http://mcccagora.com/tag/game-review/" rel="tag">game review</a>, <a href="http://mcccagora.com/tag/island/" rel="tag">island</a>, <a href="http://mcccagora.com/tag/jerry-meade/" rel="tag">Jerry Meade</a>, <a href="http://mcccagora.com/tag/new-horizons/" rel="tag">New Horizons</a>, <a href="http://mcccagora.com/tag/nintendo/" rel="tag">Nintendo</a>, <a href="http://mcccagora.com/tag/nintendo-switch/" rel="tag">nintendo switch</a>, <a href="http://mcccagora.com/tag/switch/" rel="tag">Switch</a>, <a href="http://mcccagora.com/tag/tom-nook/" rel="tag">Tom Nook</a>, <a href="http://mcccagora.com/tag/video-game/" rel="tag">video game</a>, <a href="http://mcccagora.com/tag/video-game-review/" rel="tag">video game review</a>, <a href="http://mcccagora.com/tag/video-games/" rel="tag">video games</a>, <a href="http://mcccagora.com/tag/villager/" rel="tag">villager</a></div>

        
    </footer><!-- .entry-footer -->

</article><!-- #post -->

                
            </div>

        
    </main><!-- #main -->


    <section id="sidebar">

	<div id="wpzoom-popular-views-3" class="widget popular-views">			
			<ol class="popular-posts">
												<li><a href="http://mcccagora.com/2020/04/02/covid-19-affects-construction-at-mccc/" rel="bookmark" title="Permanent Link to Covid-19 affects campus construction">Covid-19 affects campus construction</a> <span>12 views</span></li>
								<li><a href="http://mcccagora.com/2020/03/31/animal-crossing-new-horizons-gives-players-a-silver-lining/" rel="bookmark" title="Permanent Link to &#8216;Animal Crossing: New Horizons&#8217; gives players an escape">&#8216;Animal Crossing: New Horizons&#8217; gives players an escape</a> <span>44 views</span></li>
								<li><a href="http://mcccagora.com/2020/03/27/mccc-donates-loans-equipment-to-assist-during-pandemic/" rel="bookmark" title="Permanent Link to MCCC donates, loans equipment to assist during pandemic">MCCC donates, loans equipment to assist during pandemic</a> <span>42 views</span></li>
							</ol>

					 </div><div id="bs_zones-3" class="widget bs_zones"><div><broadstreet-zone zone-id="69299" keywords="not_home_page,not_landing_page,is_article_page,news,mccc-donates-loans-equipment-to-assist-during-pandemic,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div>
</section> <!-- /#sidebar -->
    

	<div class="clear"></div>

	

</div> <!-- /.page-wrap -->

<div class="clear"></div>

<div id="footer">

	<div class="footer-logo">

	    <h2><a href="http://mcccagora.com" title="">Mcccagora</a></h2>

	</div>


    
        <div class="footer-menu">
            <div class="menu-footer"><ul id="menu-footer-menu" class="menu"><li id="menu-item-1709" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1709"><a href="http://mcccagora.com/about-us/">About Us</a></li>
<li id="menu-item-1711" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1711"><a href="http://mcccagora.com/contact-us/">Contact Us</a></li>
<li id="menu-item-1713" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1713"><a href="http://mcccagora.com/advertising/">Advertising</a></li>
</ul></div>        </div>

    
	<div class="clear"></div>

	<div class="footer-info">
        <span class="copyright">
            &copy; 2020 <a href="http://www.collegemedianetwork.com/" target="_blank">College Media Network</a>, a <a href="http://www.uloop.com/" target="_blank">Uloop</a> company
        </span>
	</div>

	<div class="clear"></div>


</div> <!-- /#footer -->



<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','news','mccc-donates-loans-equipment-to-assist-during-pandemic','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["news","mccc-donates-loans-equipment-to-assist-during-pandemic","post"],"url":"mccc-donates-loans-equipment-to-assist-during-pandemic"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({});
 });</script>	  	<div id="fb-root"></div>
	  	<script><!--
			(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.10';
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));//-->
	  	</script>
	  	<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "http://mcccagora.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "80cec0284e", post_id : 4017 } ); } ); /* ]]> */</script>
<script type='text/javascript' src='http://mcccagora.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/jquery.mmenu.min.all.js?ver=4.2.0'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/flickity.pkgd.min.js?ver=4.2.0'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/jquery.carouFredSel-6.2.1-packed.js?ver=4.2.0'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/flexslider.js?ver=4.2.0'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/jquery.fitvids.js?ver=4.2.0'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/superfish.min.js?ver=4.2.0'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/tabs.js?ver=4.2.0'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/search_button.js?ver=4.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var zoomOptions = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/themes/tribune/js/functions.js?ver=4.2.0'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=20170209'></script>
<script type='text/javascript'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'http://mcccagora.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'http://mcccagora.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'http://mcccagora.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")};var heateorSssWhatsappShareAPI = "web";
</script>
<script type='text/javascript' src='http://mcccagora.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.8'></script>
<script type='text/javascript' src='http://mcccagora.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>

</body>
</html>
